Get-MSIProductInfo InstallShield Scripting Engine

Topics: Comments
Jan 27, 2015 at 9:26 AM
Hello,

Uninstall of this package (ISScript10.Msi) by default is disabled (ARPNOREMOVE=1) and the cmdlet Get-MSIProductInfo is unable to retrieve the installed version.

This package is even not listed in the Add/Remove Programs dialog (ARPSYSTEMCOMPONENT=1)

Is there a way to get installed version of such packages with PSMSI ?

Regards,
Sigmarsson
Jul 27, 2015 at 11:41 AM
Hello Guys,

Is there maybe an update on this thread ? Have you ever tried to get information about an installed MSI package built with an ARPNOREMOVE=1 ?
Aug 15, 2015 at 9:37 AM
Those properties are processed by the Programs and Features control panel and have no bearing on what MsiGetProductInfo returns. Have you checked that it's not published in a different context? Older versions of psmsi default to only the machine context.

It would help to know what version of psmsi you're using.
Aug 24, 2015 at 9:16 AM
ALLUSERS=2, so machine context and I was using the version 2.3.0.
Oct 9, 2015 at 1:33 PM
Helo Guys,

Have you tried already this to get the version number of such installed packages ?